pip安装出现Microsoft Visual C++ 14.0 is required解决方法

日期 2023年06月21日 10:52

分类 Python

标签

浏览 5625

字数统计: 714(字)

用pip去安装一些第三方包的时候会出现如下错误,缺少C++编译器,因为有些程序需要使用,没有C++接口会报错

error: Microsoft Visual C++ 14.0 is required. Get it with "Build Tools for Visual Studio": https://visualstudio.microsoft.com/downloads/

解决方案:

一、(推荐)直接下载对应版本的.whl文件,然后运行pip install xxx.whl进行安装
https://pypi.org/project/msvc-runtime/#files

二、按照提示去官网下载Visual Studio:
https://visualstudio.microsoft.com/zh-hans/downloads/

三、使用Microsoft Visual C++ Build Tools
https://aka.ms/vs/17/release/vs_BuildTools.exe

来自: https://zhuanlan.zhihu.com/p/126669852